Raco can’t install Pollen. Help!


I´m new to Racket.

I´ve written a post in github racket because I can´t install pollen. The programs says that there is a problem with the certificates. Raco can´t install a package in Windows 10 certificate Issue · Issue #4535 · racket/racket · GitHub

I am going to write my issue here as well to see if any of you can help me to sort it out.

What version of Racket are you using?
8.7 [cs]

What program did you run?
I ran the following command:

raco pkg install pollen

What should have happened?

It should have installed the package pollen. Instead, a problem appeared. The program says that it is related to SSL.

If you got an error message, please include it here.

C:\Users\DELL>raco pkg install pollen
Resolving "pollen" via https://download.racket-lang.org/releases/8.7/catalog/
Resolving "pollen" via [https://pkgs.racket-lang.org](https://pkgs.racket-lang.org/)
Downloading repository https://git.matthewbutterick.com/mbutterick/pollen.git commit c182a30f57ea5096440aea3d097f5fe3b78bb236
ssl-connect: connect failed (error:1416F086:SSL routines:tls_process_server_certificate:certificate verify failed)
C:\Program Files\Racket\collects\openssl\mzssl.rkt:368:0: error/network
C:\Program Files\Racket\collects\openssl\mzssl.rkt:1388:0: wrap-ports
C:\Program Files\Racket\collects\racket\contract\private\arrow-val-first.rkt:555:3
C:\Program Files\Racket\collects\net\http-client.rkt:67:0: http-conn-open!
C:\Program Files\Racket\collects\net\http-client.rkt:274:0: http-conn-open
C:\Program Files\Racket\collects\racket\contract\private\arrow-val-first.rkt:555:3
C:\Program Files\Racket\collects\net\url.rkt:202:0: [http://getpost-impure-port](http://getpost-impure-port/)
C:\Program Files\Racket\collects\net\url.rkt:305:0: get-pure-port/headers
C:\Program Files\Racket\collects\racket\contract\private\arrow-val-first.rkt:555:3
C:\Program Files\Racket\collects\net\git-checkout.rkt:245:0: initial-connect
C:\Program Files\Racket\collects\net\git-checkout.rkt:55:2: retry-loop
C:\Program Files\Racket\collects\pkg\private\download.rkt:102:2: download!
C:\Program Files\Racket\collects\file\cache.rkt:63:2: fetch-and-continue
C:\Program Files\Racket\collects\racket\contract\private\arrow-val-first.rkt:555:3
C:\Program Files\Racket\collects\pkg\private\download.rkt:94:0: download-repo!
C:\Program Files\Racket\collects\pkg\private\stage.rkt:319:11

Please include any other relevant details
Windows 10

If anyone can give me some assistance, I will be very grateful. I really want to give pollen a shot for a project of mine.

I’m afraid I have no idea what might cause this problem on the server side.


Yesterday night I tried like 20 times to install it and it gave me the same error over and over again.

This afternoon I tried to install it again and, surprise, it worked fine!

Thanks @mbutterick for checking it.

I will leave open the issue on racket´s github, so others might benefit from the answer that the admins might give.

Also, thanks to @joel. I saw your comment on github, but the problem was solved without any explanation.

Time to start learning Pollen to get my projects done ASAP. Xmas are almost over and work & studies will keep me busy again.